2253. Frogger

 

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

 

Input. The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2 n 200). The next n lines each contain two integers xi, yi (0 xi, yi 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n – 2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

 

Output. For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

 

Sample Input

2

0 0

3 4

 

3

17 4

19 4

18 5

 

0

 

Sample Output

Scenario #1

Frog Distance = 5.000

 

Scenario #2

Frog Distance = 1.414

 

 

РЕШЕНИЕ

графы – минимаксный путь

 

Анализ алгоритма

Следует найти такой путь в графе, в котором величина максимального ребра наименьшая.

 

Реализация алгоритма – Флойд - Уоршел

 

#include <stdio.h>

#include <math.h>

#define INF 1008611

#define MAX 210

 

double f[MAX][MAX];

double x[MAX],y[MAX];

int i, j, k, n, cs;

 

double min(double x, double y)

{

  return (x < y) ? x : y;

}

 

double max(double x, double y)

{

  return (x > y) ? x : y;

}

 

int main(void)

{

  cs = 1;

  while(scanf("%d",&n), n)

  {

    for (i = 0; i < n; i++)

      scanf("%lf %lf",&x[i],&y[i]);

    for (i = 0; i < n; i++)

    {

      f[i][i]=0;

      for (j = 0; j < n; j++)

        f[i][j] = f[j][i] = sqrt((x[i] - x[j])*(x[i] - x[j]) +

                                 (y[i] - y[j])*(y[i] - y[j]));

    }

 

    for (k = 0; k < n; k++)

    for (j = 0; j < n; j++)

    for (i = 0; i < n; i++)

      f[i][j] = min(f[i][j], max(f[i][k], f[k][j]));

 

    printf("Scenario #%d\nFrog Distance = %.3lf\n\n", cs++, f[0][1]);

  }

  return 0;

}

 

Реализация алгоритма – Минимальный остов

Строим минимальныый остов (алгоритм Крускала) пока вершины 0 (дом Фредди) и 1 (дом Фионы) не станут связными. Выводим величину максимального ребра остова.

 

#include <cstdio>

#include <cmath>

#include <algorithm>

#define MAX 210

using namespace std;

 

double f[MAX][MAX];

double x[MAX],y[MAX];

int i, j, k, n, cs, ptr;

int mas[MAX*MAX];

double res;

 

struct Edge

{

  int x, y, len;

} e[MAX*MAX];

 

int Repr(int n)

{

  if (n == mas[n]) return n;

  return mas[n] = Repr(mas[n]);

}

 

int Union(int x,int y)

{

  int x1 = Repr(x),y1 = Repr(y);

  mas[x1] = y1;

  return (x1 != y1);

}

 

int lt(Edge a, Edge b)

{

  return (a.len < b.len);

}

 

int main(void)

{

  cs = 1;

  while(scanf("%d",&n), n)

  {

    for (i = 0; i < n; i++)

      scanf("%lf %lf",&x[i],&y[i]);

 

    res = ptr = 0;

    for (i = 0; i < n; i++)

      for (j = i + 1; j < n; j++)

        if (i != j)

        {

          e[ptr].len = (x[i] - x[j])*(x[i] - x[j]) +

                       (y[i] - y[j])*(y[i] - y[j]);

          e[ptr].x = i;

          e[ptr].y = j;

          ptr++;

        }

 

    sort(e,e+ptr,lt);

    for(i = 0; i < n; i++) mas[i] = i;

 

    for(i = 0; i < ptr; i++)

    {

      if(Union(e[i].x,e[i].y))

        res = max(res,sqrt(1.0*e[i].len));

      if (Repr(0) == Repr(1)) break;

    }

 

    printf("Scenario #%d\nFrog Distance = %.3lf\n\n", cs++, res);

  }

  return 0;

}